summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoberto Rossini2019-11-04 13:32:38 +0100
committerRoberto Rossini2019-11-04 13:32:38 +0100
commite44141d75e458d393f205ba019bf1fc25b0bfb8e (patch)
treed33640530f0437d3f5991c858841a32399e6d467 /PKGBUILD
parent6fe2dbe2964c3a9caf977c82b77431da982f25b5 (diff)
downloadaur-diamond-aligner-git.tar.gz
Update diamond to v0.9.27 and apply minor improvements to PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e6941daff72..f7d10d5d51ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Roberto Rossini ("robymetallo") <roberto.rossini.9533@student.uu.se>
+_name=diamond
pkgname=diamond-aligner-git
-pkgver=0.9.24.r46.gd333bab
-pkgrel=2
-pkgdesc="Accelerated BLAST compatible local sequence aligner"
+pkgver=0.9.27.r1.g58ee82e
+pkgrel=1
+pkgdesc='Accelerated BLAST compatible local sequence aligner'
url='https://github.com/bbuchfink/diamond'
arch=('x86_64')
@@ -13,23 +14,22 @@ license=('GPL3')
depends=('gcc-libs' 'zlib')
makedepends=('cmake' 'git')
-source=("git+https://github.com/bbuchfink/diamond.git")
+source=("git+https://github.com/bbuchfink/$_name.git")
sha256sums=('SKIP')
pkgver() {
- cd diamond
+ cd $_name
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- ln -s diamond diamond-$pkgver
- mkdir -p diamond-$pkgver/build
+ mkdir $_name/build
}
build() {
- cd diamond-$pkgver/build
+ cd $_name/build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
..
@@ -39,14 +39,14 @@ build() {
}
check() {
- cd diamond-$pkgver/build
- ./diamond --version
+ cd $_name/build
+ ./$_name --version
}
package() {
- cd diamond-$pkgver/build
+ cd $_name/build
make DESTDIR="$pkgdir" install
+
}
-