summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-29 04:33:55 +0200
committerChristopher Arndt2022-09-29 04:33:55 +0200
commitbc85bed287cda8fb5312d2d6a6cb5a29928dd3c9 (patch)
treeb393ce57cc6f33cfae2430022f6dea0208e335d2 /PKGBUILD
parent2350ef6519c9a5344254edfd9b42fa37557d7432 (diff)
downloadaur-die-plugins.lv2-git.tar.gz
Packaging fixes and improvemnts
* Added to "pro-audio" group * Moved "glib2" to makedepends and add soname dep * Added "gcc-libs" to depends * Added "die-plugins" to provides and conflicts * Simplified PKGBUIDLD syntax
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd3557e5574e..2a62358fc67f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
_name=DIE-Plugins
-_pkgname="${_name,,}.lv2"
-pkgname="${_pkgname}-git"
+_pkgname=${_name,,}.lv2
+pkgname=$_pkgname-git
pkgdesc="DISTRHO Imported Effect Plugins, Ardour's plugins without Ardour (git version)"
-pkgver=1.1.r4.gf8a31d5
+pkgver=1.1.r13.gb196b7e
pkgrel=1
arch=(x86_64)
-url="https://github.com/DISTRHO/${_name}"
-license=('GPL2')
-groups=('lv2-plugins')
-depends=('glibc' 'glib2')
-makedepends=('git' 'libsndfile' 'lv2')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/DISTRHO/${_name}")
+url="https://github.com/DISTRHO/$_name"
+license=(GPL2)
+groups=(lv2-plugins pro-audio)
+depends=(glibc gcc-libs)
+makedepends=(git glib2 libsndfile lv2)
+optdepends=('lv2-host: for loading LV2 plugins')
+provides=($_pkgname ${_name,,})
+conflicts=($_pkgname ${_name,,})
+source=("$_pkgname::git+https://github.com/DISTRHO/$_name")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -27,13 +28,13 @@ pkgver() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
make
}
package() {
- depends+=('libsndfile.so')
- cd "${srcdir}/${_pkgname}"
+ depends+=(libglib-2.0.so libsndfile.so)
+ cd $_pkgname
make DESTDIR="$pkgdir" PREFIX="/usr" install
- chmod +x "${pkgdir}"/usr/lib/lv2/*.lv2/*.so
+ chmod +x "$pkgdir"/usr/lib/lv2/*.lv2/*.so
}