summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorniwatolli32017-09-17 16:43:16 +0900
committerniwatolli32017-09-17 16:43:16 +0900
commit769698fa3fab4ef239d5f4c9b058ac11ddb03e42 (patch)
tree745e832d36dfa5bb6d32ac23cd6837dda0ffa08a /PKGBUILD
downloadaur-digdag-bin.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c51ac98f9bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Takuya Tominaga <takuya.tominaga.public at gmail dot com>
+
+_pkgname=digdag
+pkgname=$_pkgname-bin
+pkgver=0.9.16
+pkgrel=1
+pkgdesc="Workload Automation System."
+arch=('i686' 'x86_64')
+url="https://github.com/treasure-data/digdag"
+license=('Apache')
+depends=('jdk8-openjdk' 'nodejs')
+
+_dl_url=https://dl.digdag.io
+source_i686=("$_dl_url/$_pkgname-$pkgver"
+)
+source_x86_64=("$_dl_url/$_pkgname-$pkgver"
+)
+md5sums_i686=('SKIP'
+)
+md5sums_x86_64=('SKIP'
+)
+
+
+
+package() {
+ _source_arch="32"
+ [ "$CARCH" = "x86_64" ] && _source_arch="64"
+
+ install -Dm755 "$srcdir/$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+}
+