summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrozap2021-12-15 03:36:23 -0600
committercyrozap2021-12-15 03:36:23 -0600
commit31a5716759a965269415f6bbb7198bc51b458d22 (patch)
treebe7be8ebc56f3ed3e0a16597f6f88311d3b77758 /PKGBUILD
parent23925700a005f9ad41cd27f9819ae55014e36474 (diff)
downloadaur-31a5716759a965269415f6bbb7198bc51b458d22.tar.gz
Add support for aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be90d0fc04fb..4d92e57af787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,18 @@ pkgname=digilent.waveforms
pkgver=3.16.3
pkgrel=1
pkgdesc="Digilent WaveForms Application, Runtime and SDK"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://reference.digilentinc.com/waveforms3"
license=('custom')
depends=('desktop-file-utils' 'digilent.adept.runtime' 'qt5-multimedia' 'qt5-script' 'shared-mime-info' 'xdg-utils')
options=('!strip')
install=${pkgname}.install
+source_aarch64=("https://digilent.s3.amazonaws.com/Software/Waveforms2015/${pkgver}/${pkgname}_${pkgver}_arm64.deb")
source_armv6h=("https://digilent.s3.amazonaws.com/Software/Waveforms2015/${pkgver}/${pkgname}_${pkgver}_armhf.deb")
source_armv7h=($source_armv6h)
source_i686=("https://digilent.s3.amazonaws.com/Software/Waveforms2015/${pkgver}/${pkgname}_${pkgver}_i386.deb")
source_x86_64=("https://digilent.s3.amazonaws.com/Software/Waveforms2015/${pkgver}/${pkgname}_${pkgver}_amd64.deb")
+sha256sums_aarch64=('fb48478b7d30878ad9ad903717b79598830117b7e7c213195531787ddad822ae')
sha256sums_armv6h=('0ae5eae3b9f35eca1a1087667a1f97ffb5c5f701ce82b6423d371d4dda09a084')
sha256sums_armv7h=($sha256sums_armv6h)
sha256sums_i686=('eb5fcb725eb083ebbd2b0d244ae4a00518109502543941196b591e90821ec732')