summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-12-30 23:51:30 +0100
committerJ5lx2015-12-30 23:51:30 +0100
commita08f84eb3194d93ab47a3488c07b3d47eaeb753f (patch)
tree02a37b2b700b37f97a03f26213d5e8481144463d /PKGBUILD
downloadaur-django-transaction-hooks.tar.gz
0.2-1: Initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2056a7f1bcfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgbase=django-transaction-hooks
+pkgname=('python-django-transaction-hooks' 'python2-django-transaction-hooks')
+pkgver=0.2
+pkgrel=1
+pkgdesc="Django database backends that permit registering post-transaction-commit hooks"
+arch=('any')
+license=('BSD')
+url="https://github.com/carljm/django-transaction-hooks"
+makedepends=('python' 'python-setuptools' 'python-django' 'python2'
+ 'python2-setuptools' 'python2-django')
+source=("https://github.com/carljm/django-transaction-hooks/archive/v${pkgver}.tar.gz")
+md5sums=('fad01e8733d0bea7dc0e6d69a47e31fb')
+
+package_python-django-transaction-hooks() {
+ depends=('python' 'python-django')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" -O1
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
+
+package_python2-django-transaction-hooks() {
+ depends=('python2' 'python2-django')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ python2 setup.py install --root="${pkgdir}" -O1
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}