summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Luna2018-01-10 20:48:21 -0600
committerChristopher Luna2018-01-10 20:48:21 -0600
commit3f6a22372a2c153f04fa8d0b27af0085706fe552 (patch)
tree69a1116a0e5d2ff957754a807b25f28ff75cd4a3 /PKGBUILD
downloadaur-dkms-hid-sony-shanwan.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65b9cf17c94a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=dkms-hid-sony-shanwan
+_pkgname=hid-sony
+pkgver=1
+pkgrel=1
+pkgdesc='The hid-sony driver patched to fix the non-stop rumbling bug with the Shanwan gamepads (clones of Dualshock 3)'
+url='https://github.com/raspberrypi/linux/commit/492ca83c3d19fba1622164f07cd7b775596a7db2'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('dkms')
+makedepends=('linux-headers')
+
+source=('Makefile'
+ 'dkms.conf'
+ 'hid-sony.c'
+ 'hid-ids.h')
+
+md5sums=('5cbe7c99718d8b1486b22bf727018fab'
+ '56200443eb4c01b755de1ec7c423eadc'
+ 'b79d3c0ce5f2734df35ecf11ea07f572'
+ '2422777cff8d52214762dccb0bd062ea')
+
+install=hid-sony.install
+
+package() {
+ cd "${srcdir}"
+ mkdir -p ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L Makefile ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L dkms.conf ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L hid-sony.c ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+ cp -L hid-ids.h ${pkgdir}/usr/src/${_pkgname}-${pkgver}
+}