summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSiHuan2021-01-23 20:20:13 +0800
committerSiHuan2021-01-23 20:20:13 +0800
commit7173e3fd838951b4ac711f493018ef55830762ae (patch)
treee2525d54ac0d14cb9bc18db7b2f9c355e6dbae43 /PKGBUILD
parent6c3a8e93f7fa6d49ec5b0b3e7e7526f7e5bc0b02 (diff)
downloadaur-dockfmt-git.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4e4e2443dd4..2e00ce585c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
_pkgname=dockfmt
pkgname=$_pkgname-git
pkgver="r59.1455059"
-pkgrel=1
+pkgrel=2
pkgdesc='Dockerfile format and parser. Like `gofmt` but for Dockerfiles.'
arch=('x86_64')
url="https://github.com/jessfraz/$_pkgname"
license=('MIT')
-depends=()
+depends=('glibc')
makedepends=('git' 'go')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -17,26 +17,16 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-
-}
-
-prepare() {
- cd "$srcdir/$_pkgname"
- go mod vendor
}
build() {
# export GOPROXY=https://goproxy.cn,direct
cd "$srcdir/$_pkgname"
- go build \
- -gcflags "all=-trimpath=${PWD}" \
- -asmflags "all=-trimpath=${PWD}" \
- -ldflags "-extldflags ${LDFLAGS}" \
- -o "$_pkgname" .
+ make
}
package() {
cd "$srcdir/$_pkgname"
install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"}
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"}
}