summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYaohan Chen2018-09-22 04:24:16 -0400
committerYaohan Chen2018-09-22 04:24:16 -0400
commit7fe24d8e83fd22f092ce9444f882238648f8489c (patch)
tree284d8fa26a72ab1a90f2c20c3e3effa933e56335 /PKGBUILD
parent3e98ccffdd3e31964b77acb74a22447ac58af8a2 (diff)
downloadaur-dofus-beta.tar.gz
Update dependencies, remove Air wrapper
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 5 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0a073f747ed..0e992784df1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,27 @@
# Contributor: spider-mario <spidermario@free.fr>
# Contributor: p2k <Patrick.Schneider@uni-ulm.de>
# Contributor: Schtroumpfette <fpeterschmitt@voila.fr>
-
-# 1: use adl to launch the game. Otherwise, use official game binaries directly.
-USE_ADL=1
+# Contributor: Genesis <tofupedia.fr@gmail.com>
pkgname=dofus-beta
-pkgver=2.46
+pkgver=2.48
pkgrel=1
pkgdesc='A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR (Beta version).'
arch=('i686' 'x86_64')
url='http://www.dofus.com/'
license=('custom:Dofus License')
install='dofus-beta.install'
-depends=('adobe-air-sdk' 'qt5-base' 'libpng12')
-depends_x86_64+=('lib32-gtk2' 'lib32-alsa-lib' 'lib32-alsa-plugins')
-depends_i686+=('gtk2' 'alsa-lib' 'alsa-plugins')
-optdepends=('pulseaudio-alsa: Required for the game to play sounds with PulseAudio')
+depends=('libpng12' 'wine')
source=('dofus-beta.desktop'
- 'dofus-beta.sh'
- 'air-generic-launcher.sh'
- 'transition.conf.patch')
+ 'dofus-beta.sh')
source_i686=('http://dl.ak.ankama.com/games/installers/beta/dofus-beta-x86.tar.gz')
source_x86_64=('http://dl.ak.ankama.com/games/installers/beta/dofus-beta-amd64.tar.gz')
md5sums=('0e797e4fcf39e1d06f68b51bfd215040'
- 'cecd52aa9a58f756fa15925528400d66'
- '092f6852a6ea603a7b8c7175a13eb416'
- '28fa5927aad634debf7f1ff9f549f59c')
+ 'c30ea01c11808930ae968e09272929d5')
md5sums_i686=('01ce4e20df355f9a5724ef5c5b880cbf')
md5sums_x86_64=('7566e58290a158e12156ef8ab608c7d0')
-prepare() {
- if [ "$USE_ADL" -eq "1" ]
- then
- cd "$srcdir"
- msg2 'Modifying transition configuration to use adl-based launchers'
- patch -p0 < transition.conf.patch
- fi
-}
-
package() {
msg2 'Installing main applications...'
installdir='opt/ankama/dofus-beta'
@@ -50,9 +32,6 @@ package() {
msg2 'Setting up game file permissions...'
chgrp -R games "$pkgdir/$installdir"
chmod -R g+w "$pkgdir/$installdir"
- install -dm775 "$pkgdir/$installdir/bin"
- install -dm775 "$pkgdir/$installdir/share/reg/"
- install -dm775 "$pkgdir/$installdir/share/reg/bin"
msg2 'Installing launcher...'
install -Dm755 "$srcdir/dofus-beta.sh" "$pkgdir/usr/bin/dofus-beta"
@@ -64,16 +43,6 @@ package() {
size="$(basename "$icon" | grep -o '[0-9]\+x[0-9]\+')"
install -Dm644 "$icon" "$pkgdir/usr/share/icons/hicolor/$size/apps/dofus-beta.png"
done
-
- if [ "$USE_ADL" -eq "1" ]
- then
- msg2 'Installing adl based launchers...'
- install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/bin/air-generic-launcher.sh"
- install -Dm755 'air-generic-launcher.sh' "$pkgdir/$installdir/share/reg/bin/air-generic-launcher.sh"
- else
- msg2 'Installing link to bypass Adobe Air detection...'
- ln -s '/opt/adobe-air-sdk/runtimes/air/linux/Adobe AIR/' "$pkgdir/opt/Adobe AIR"
- fi
}
# vim:set ts=2 sw=2 et: