summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Hornich2020-09-16 15:59:19 +0200
committerJulian Hornich2020-09-16 15:59:19 +0200
commita41af752a47a05e9bdb81c8406840b9ef3ada0a1 (patch)
tree5f9da5836e47dd794dd8d81033404b3b06f0f279 /PKGBUILD
parent45ff0668464fb30354caf9870ebce10370e0aba2 (diff)
downloadaur-dolfin-hpc.tar.gz
update to version 0.9.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f67c66dc2e4..fb06b2b292be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Julian Hornich <hornich at kth dot se>
pkgname=dolfin-hpc
-pkgver=0.9.1_hpc_20200720
+pkgver=0.9.2_hpc_20200914
pkgrel=1
pkgdesc="DOLFIN HPC is a special branch of DOLFIN optimized for distributed memory architectures"
-_tag=0.9.1-hpc
+_tag=0.9.2-hpc
arch=('i686' 'x86_64')
url="https://bitbucket.org/adaptivesimulations/dolfin-hpc/"
license=('LGPL')
@@ -22,13 +22,15 @@ pkgver() {
echo "${_tag}_$(git log --format="%cd" --date=short -1 | sed 's/-//g')" | sed 's/-/_/g'
}
+_petsc_dir=/opt/petsc/linux-c-opt
+
prepare() {
cd dolfin-hpc
sh regen.sh
- ./configure --prefix=${pkgdir}/opt/dolfin PYTHON=python3 CXXFLAGS="-O3 -march=native -std=c++14" \
- --with-petsc=/opt/petsc/linux-c-opt --with-gts --enable-python --with-parmetis \
- --enable-quadrature --enable-mpi --enable-mpi-io --with-phmap --enable-function-cache \
- --enable-optimize-p1 --enable-opt-basis
+ ./configure --prefix=${pkgdir}/opt/${pkgname} PYTHON=python3 CXXFLAGS="-O3 -march=native" \
+ --with-petsc=${_petsc_dir} --with-gts --enable-python --with-parmetis \
+ --enable-quadrature --enable-mpi --enable-mpi-io --with-phmap --enable-function-cache \
+ --enable-optimize-p1 --enable-opt-basis --with-convert
}
build() {