summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-10-04 21:02:01 -0700
committerxiota2023-10-04 21:02:01 -0700
commit7e3ddb54f79a4cf5757662fc5cad70ee10babe87 (patch)
tree32cc050a09b32380dbe1dabee348194ba4e1ee68 /PKGBUILD
parentf48dce43bca9e4b4ccfc095ad1cc4e5198bd6e31 (diff)
downloadaur-dolphin-emu-osvr-git.tar.gz
metapackage
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 9 insertions, 50 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c29bc01fe58..02dcb5931c62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,20 @@
-# Maintainer: Zachary Jaggi <feilen1000@gmail.com>
-
+_newpkg='dolphin-emu'
pkgbase=dolphin-emu-osvr-git
pkgname=('dolphin-emu-osvr-git' 'dolphin-emu-osvr-cli-git')
-pkgver=4.0.2.r8742.5b7c294
+pkgver=0.0.1
pkgrel=1
-pkgdesc='A GameCube / Wii / Triforce emulator, with OSVR cross-HMD support'
-arch=('x86_64')
-url='http://www.dolphin-emu.org/'
-license=('GPL2')
-depends=('bluez-libs' 'ffmpeg' 'libao' 'mbedtls' 'miniupnpc' 'portaudio'
- 'sdl2' 'sfml' 'soundtouch' 'xdg-utils' 'wxgtk' 'osvr-core-git' 'osvr-libfunctionality-git')
-makedepends=('cmake' 'git')
-optdepends=('pulseaudio: PulseAudio backend')
-options=('!emptydirs')
-source=('dolphin-emu::git+https://github.com/feilen/dolphin.git#branch=osvr')
-sha256sums=('SKIP')
-
-pkgver() {
- cd dolphin-emu
-
- tag='4.0.2'
-
- echo "${tag}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
-}
-
-build() {
- cd dolphin-emu
+epoch=1
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_CXX_FLAGS='-fno-inline-functions -fpermissive' \
- -DENABLE_LTO='TRUE'
- make
+_package() {
+ depends=("$_newpkg")
}
package_dolphin-emu-osvr-git() {
- provides=('dolphin-emu')
- conflicts=('dolphin-emu')
-
- cd dolphin-emu/build
-
- make DESTDIR="${pkgdir}" install
- rm -rf "${pkgdir}"/usr/bin/dolphin-emu-nogui
+ depends=("$_newpkg")
}
package_dolphin-emu-osvr-cli-git() {
- depends=('dolphin-emu-osvr-git')
-
- cd dolphin-emu/build
-
- install -dm 755 "${pkgdir}"/usr/bin
- install -m 755 Binaries/dolphin-emu-nogui "${pkgdir}"/usr/bin/dolphin-emu-cli
+ depends=("$_newpkg")
}
-
-# vim: ts=2 sw=2 et: