summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:03 +0200
committerSébastien Leduc2015-06-13 10:51:03 +0200
commit3907d23af44908c3e22a503121adfb1dd5d7b36d (patch)
treefe817c4859b8668837fb4a74160526f1780325da /PKGBUILD
downloadaur-dothost-hg.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b53e6f102d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: S.Leduc <sebastien@sleduc.fr>
+pkgname=dothost-hg
+_hgname=dothost
+pkgrel=1
+pkgver=3.385591fa3319
+pkgdesc="dothost is a DNS lookup utility, which produces output in Graphviz format."
+arch=("any")
+url="http://jwilk.net/software/dothost"
+license=('MIT')
+depends=('python')
+makedepends=('mercurial')
+optdepends=('graphviz: Graph visualization software for lddot output'
+ 'perl-graph-easy: Convert or render graphs to ASCII/Image')
+source=("${_hgname}::hg+https://bitbucket.org/jwilk/${_hgname}")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_hgname"
+ echo "$(hg identify -n).$(hg identify -i)"
+}
+
+package() {
+ cd "$_hgname"
+ install -D -m 0755 $_hgname "$pkgdir/usr/bin/$_hgname"
+}
+
+# vim:set ts=2 sw=2 et: