summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Heinrich2019-08-05 13:20:30 +0200
committerJonas Heinrich2019-08-05 13:20:30 +0200
commitb3ff03802a79e45fed2b4a43cfd2278bddc7cc43 (patch)
tree59e18ae87a37c5900d0fcc657010483ea0c6017d /PKGBUILD
parent601e3d1bd54ea3e6d314aa02b3723fcf8ddc10fc (diff)
downloadaur-dotnet-runtime-bin.tar.gz
fix host/fxr path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85e22e3da09f..81e10dd588d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,15 @@
pkgname=dotnet-runtime-bin
pkgver=2.2.6
-pkgrel=2
+pkgrel=3
pkgdesc="The .NET Core runtime (binary version)"
arch=("x86_64" "armv7h" "aarch64")
url="https://github.com/dotnet/core"
license=('MIT')
provides=('dotnet-runtime')
conflicts=('dotnet-runtime')
+source=("dotnet.sh")
+sha512sums=('181ccf9499e1b38576b7f87eb04c1fad7aede4b7e56d246e00ca7956ec15996221862db00a2a5014bdb482eb5a363ca49fc6b661909d2d9e22a374318c5c0066')
source_armv7h=("https://download.visualstudio.microsoft.com/download/pr/428aaa32-f66c-4847-b845-aa21f90504e4/1cf033db866414997140c2672bd75069/dotnet-runtime-2.2.6-linux-arm.tar.gz")
source_x86_64=("https://download.visualstudio.microsoft.com/download/pr/9f21e352-9d2c-4e3b-af45-915da89158db/0e8a7ea83cc08d4bcf417a927a36ed6f/dotnet-runtime-2.2.6-linux-x64.tar.gz")
source_aarch64=("https://download.visualstudio.microsoft.com/download/pr/f5e04830-50fc-435c-8bb5-fcd4629da944/8aa7cce5c3fcb6a7db180b923d3574ef/dotnet-runtime-2.2.6-linux-arm64.tar.gz")
@@ -19,9 +21,11 @@ sha512sums_aarch64=('55a14b94ae5b981d8ac6218edd2d8119776e778f094071fcf0f9e42affe
options=('!strip')
package() {
- install -D "${srcdir}/dotnet" "${pkgdir}/usr/bin/dotnet"
install -D "${srcdir}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/share/dotnet-runtime"
- cp -r "${srcdir}/host" "${pkgdir}/usr/bin/"
+ install -dm 755 "${pkgdir}/usr/share/dotnet-runtime"
+ install -D "${srcdir}/dotnet" "${pkgdir}/usr/share/dotnet-runtime/dotnet"
+ cp -r "${srcdir}/host" "${pkgdir}/usr/share/dotnet-runtime/"
cp -r "${srcdir}/shared" "${pkgdir}/usr/share/dotnet-runtime/"
+ install -Dm 755 "${srcdir}"/dotnet.sh "${pkgdir}"/usr/bin/dotnet
}