summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2024-03-20 15:00:29 +0100
committerbartus2024-03-20 15:00:29 +0100
commitbef188e9097e3f21ad1729f64d82bded5b35c2c3 (patch)
treec8d55d08ef7e397b14444976a412e50ebf8e2417 /PKGBUILD
parentd7820094bfd1303e765d316b09bb4a82c8fd0f2f (diff)
downloadaur-draco-git.tar.gz
Update pkgver() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 428752653cea..3d55ccc6534c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
basename=draco
pkgname=$basename-git
-pkgver=1.5.6
+pkgver=1.5.7.r1.g7d58126
pkgrel=1
pkgdesc="Draco is a library for compressing and decompressing 3D geometric meshes and point clouds. It is intended to improve the storage and transmission of 3D graphics."
arch=('x86_64')
@@ -15,7 +15,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${basename}"
- git describe --tags | sed 's/-/+/g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {