summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortimescam2022-01-24 16:30:07 +0800
committertimescam2022-01-24 16:30:07 +0800
commitf326a26f22ffd0d312a6f3deda4b0987cbeaaeb4 (patch)
treeb2f95fdf857093d31c3dddf7d8724acbed961607 /PKGBUILD
downloadaur-dracula-cursors-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bbea0828680
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: timescam <timescam at duck dot com>
+pkgname=dracula-cursors-git
+_pkgname=gtk
+pkgver=v3.0.r5.gfa54bba
+pkgrel=1
+pkgdesc="Dracula theme cursors"
+arch=("any")
+url="https://github.com/dracula/${_pkgname}"
+license=("GPL3")
+provides=("dracula-cursors")
+makedepends=("git")
+source=("git+https://github.com/dracula/${_pkgname}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+package() {
+ cd "${_pkgname}/kde"
+ mkdir -p "${pkgdir}/usr/share/icons"
+ cp -r cursors/Dracula-cursors "${pkgdir}/usr/share/icons"
+}