summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbjorkbjork2025-02-27 15:34:17 +1100
committerbjorkbjork2025-02-27 15:34:17 +1100
commitf10574d472c1c8d33185b8c2ae275d8a5ccf76b9 (patch)
tree8d46b772885fa7e304d789472d5f7901e9ded06d /PKGBUILD
downloadaur-drawboard-pdf.tar.gz
Initial commit for drawboard-pdf
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09913bb001a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: <francois@francoisvankempen.com>
+options=('!debug')
+pkgname=drawboard-pdf
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Electron wrapper for Drawboard PDF software"
+arch=('x86_64')
+url=""
+license=('MIT') # Change if needed
+depends=('electron' 'gtk3')
+makedepends=('nodejs' 'npm')
+source=("https://github.com/bjorkbjork/DrawboardPDF-Linux/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz") # Replace with your release source if hosting
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir"
+ npm ci
+ npx electron-packager . "$pkgname" --platform=linux --arch=x64 --icon=assets/icon.png --out=dist/
+}
+
+package() {
+ install -dm755 "$pkgdir/usr/lib/$pkgname"
+ cp -r "dist/$pkgname-linux-x64/"* "$pkgdir/usr/lib/$pkgname"
+
+ install -Dm755 "$pkgdir/usr/lib/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ install -Dm644 assets/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
+