summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2022-09-21 21:29:43 +0300
committerViktor Drobot2022-09-21 21:29:43 +0300
commit54c2de7a176d2b94a1491ab11c1084c3fa26d738 (patch)
tree0044c2b5de8d0fb3621e9080d63b26cfa9af4536 /PKGBUILD
parent4de15826a5e7cf6c40a1dbd5cecbcf04a4f0d325 (diff)
downloadaur-dream.tar.gz
Fix hamlib build issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0191a9b9e1eb..542ae2f1279a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=dream
pkgver=2.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="A software radio for AM and Digital Radio Mondiale (DRM)"
arch=(i686 x86_64)
url="https://sourceforge.net/projects/drm"
@@ -10,14 +10,17 @@ license=(GPL2)
depends=(faad2 libpcap libpulse fftw opus libsndfile speexdsp hamlib libpulse qwt qt5-webkit qt5-svg qt5-base)
makedepends=(patch)
source=("https://sourceforge.net/projects/drm/files/dream/${pkgver}/${pkgname}-${pkgver}-svn808.tar.gz"
- "fix_qwttext.patch")
+ "fix_qwttext.patch"
+ "fix_hamlib.patch")
sha256sums=('417734a197ed596a08e75363c304be9b4595f2f21581bc64fec47c49f733bb05'
- 'a5c521644f9a95f73adc4eefa8bb690642caefa59b028ddd9b34aea231af96f2')
+ 'a5c521644f9a95f73adc4eefa8bb690642caefa59b028ddd9b34aea231af96f2'
+ 'df8dbc1f5c2e6e181377bf7832dbf057018dd1be2b9cdfa8d9a24db3f0f9b76a')
build() {
cd "${srcdir}/${pkgname}"
patch -Np0 -i "${srcdir}/fix_qwttext.patch"
+ patch -Np0 -i "${srcdir}/fix_hamlib.patch"
qmake-qt5 dream.pro
make