summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMateusz Gozdek2020-09-19 19:20:18 +0200
committerMateusz Gozdek2020-09-19 19:20:18 +0200
commit50b5f249347dae109f108eb77e46d3e69b3f3544 (patch)
tree86899132dbaa5ae7f4b630d4178fb3f93437881d /PKGBUILD
parentf47f5af55a78e401319119f074ebef933d07ca10 (diff)
downloadaur-50b5f249347dae109f108eb77e46d3e69b3f3544.tar.gz
Fix building if one has '.' in $PATH
As then linux/install script from repository is used instead of /usr/bin/install, which is incorrect. Signed-off-by: Mateusz Gozdek <mgozdekof@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dd52df112e0..27a203fc885d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=droidcam
pkgname=('droidcam' 'v4l2loopback-dc-dkms')
pkgver=1.4
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='A tool for using your android device as a wireless/usb webcam'
arch=('x86_64')
@@ -35,6 +35,10 @@ prepare() {
# Apply patches.
cd "${pkgname}-${pkgver}"
patch -p0 --input="${srcdir}/0001-Makefile-allow-to-modify-how-to-link-to-libusbmuxd.patch"
+
+ # Ensure that 'install' script from repository does not collide with install binary used for
+ # building the package.
+ chmod -x ./linux/install
}
build() {