summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAbdelhak Bougouffa2022-08-01 18:02:43 +0200
committerAbdelhak Bougouffa2022-08-01 18:02:43 +0200
commit7edb8a615c325a471cfb22b05d2056aeb1c89a94 (patch)
tree909603794594c29b22dfd5ea43d6fb94a7d603cf /PKGBUILD
parent3df317ede5c87fcd0fc052f7b9befe43b3c4c987 (diff)
downloadaur-7edb8a615c325a471cfb22b05d2056aeb1c89a94.tar.gz
fix: new installation procedure
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c18df9827c24..21fe1e3669f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor: Thomas Krug <t.krug@elektronenpumpe.de>
pkgname=dsview-git
-pkgver=1.12.r81.ga80c82d
+pkgver=1.2.0.r14.g1d249ff
pkgrel=1
pkgdesc='GUI programe for supporting various instruments from DreamSourceLab, including logic analyzer, oscilloscope, etc.'
arch=(i686 x86_64)
url='http://www.dreamsourcelab.com/'
license=(GPL3)
# Upstream added VCS dependency to libsigrokdecode :/
-depends=(boost-libs qt5-base fftw libsigrok4dsl-git libsigrokdecode4dsl-git)
+depends=(boost-libs qt5-base fftw)
makedepends=(boost cmake)
-source=(git://github.com/DreamSourceLab/DSView) #branch=develop
+source=(git+https://github.com/DreamSourceLab/DSView) #branch=develop
sha1sums=('SKIP')
pkgver() {
@@ -20,20 +20,20 @@ pkgver() {
}
prepare() {
- cd DSView/DSView
- sed 's|/usr/local/|/usr/|' -i DSView.desktop
+ cd DSView
+ sed 's|/usr/local/|/usr/|' -i DSView/DSView.desktop
sed 's| /lib/udev/rules.d| /usr/lib/udev/rules.d|' -i CMakeLists.txt
}
build() {
- cd DSView/DSView
+ cd DSView
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd DSView/DSView
+ cd DSView
make DESTDIR="$pkgdir" install
#install -Dm644 icons/logo_color.png "$pkgdir/usr/share/pixmaps/dsview.png"