summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrevel2021-09-13 11:35:05 +0200
committerrevel2021-09-13 11:35:05 +0200
commit4fc409c804ebff298c7b2cdaeb7ccddec4965560 (patch)
tree59c1d72b31af7e530c029960fcf2b0318dacdf51 /PKGBUILD
parent9b9c156f712574173e961bb5d072dfabb719f014 (diff)
downloadaur-duma.tar.gz
- fixed building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ced2893a42e..3926d63adba6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,32 @@
pkgname=duma
pkgver=2.5.21
-pkgrel=1
+pkgrel=2
pkgdesc='Detect Unintended Memory Access (D.U.M.A.) - A Red-Zone memory allocator'
arch=('i686' 'x86_64')
url='https://github.com/johnsonjh/duma'
license=('GPL')
depends=('bash' 'gcc-libs')
_pkgver="${pkgver//./_}"
-source=("https://github.com/johnsonjh/duma/archive/refs/tags/VERSION_${_pkgver}.tar.gz")
-sha256sums=('470aa72e7018f0beadb5fbe3c932a62ba1b0594c29158a744c614bfa42133e59')
+source=("https://github.com/johnsonjh/duma/archive/refs/tags/VERSION_${_pkgver}.tar.gz"
+ "tests_dynamic_exceptions.patch")
+sha256sums=('470aa72e7018f0beadb5fbe3c932a62ba1b0594c29158a744c614bfa42133e59'
+ 'b83fdf43711da3ff065592da9c45fe6efd422e4f9585159e1e11dc327307697b')
prepare() {
cd "${pkgname}-VERSION_${_pkgver}"
# sed -i 's/CPPFLAGS=/\0-std=gnu++98 /g' GNUmakefile
+ patch -p1 -i ../tests_dynamic_exceptions.patch
}
build() {
cd "${pkgname}-VERSION_${_pkgver}"
- make
+ make --jobs=1
}
check() {
cd "${pkgname}-VERSION_${_pkgver}"
-# make check
+ make check
}
package() {