summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-12 22:38:45 -0500
committerCarlos Aznarán2024-04-12 22:38:45 -0500
commit73bdd4f914082c4c3492c5d68a921309f368ce42 (patch)
tree824ae1346f33158b6df39d61023d76fef4f349cb /PKGBUILD
parent4e362d4b06c44e283a6ba6805da86c423845c7ba (diff)
downloadaur-dumux-precice.tar.gz
Fix path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43673b98c84b..ab7b919fea0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,18 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
pkgname=dumux-precice
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="DuMuX-preCICE adapter"
arch=(x86_64)
url="https://github.com/precice/${pkgname/precice/adapter}"
license=(GPL-3.0-or-later)
depends=(dumux precice)
-makedepends=(cmake)
source=(${pkgname/precice/adapter}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('466f685641619c734149d19e40b270872b70818041f0bfd2b10d0ea9f33c8e4ebfb822708fa7db25eabfd8d3f645fbc9c36caa0047772947c6bb3d18bead2e3f')
prepare() {
sed -i 's/DumuxPreciceTestMacros.cmake/#DumuxPreciceTestMacros.cmake/' ${pkgname/precice/adapter}-${pkgver}/cmake/modules/CMakeLists.txt
- sed -i '2 a \ \ \ \ dumuxpreciceindexmapper.hh' ${pkgname/precice/adapter}-${pkgver}/${_base}/CMakeLists.txt
+ sed -i '2 a \ \ \ \ \ \ \ \ dumuxpreciceindexmapper.hh' ${pkgname/precice/adapter}-${pkgver}/${pkgname}/CMakeLists.txt
# https://stackoverflow.com/a/50949315/9302545
sed -i 's/return/exit/' ${pkgname/precice/adapter}-${pkgver}/test/return-test-passed.sh
}
@@ -37,11 +36,6 @@ build() {
cmake --build build --target all
}
-check() {
- cmake --build build --target build_tests
- ctest --verbose --output-on-failure --test-dir build
-}
-
package() {
DESTDIR="${pkgdir}" cmake --build build --target install
install -Dm 644 ${pkgname/precice/adapter}-${pkgver}/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"