summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreshrh2022-03-07 14:08:50 -0500
committereshrh2022-03-07 14:08:50 -0500
commit7495c38b14f714ed1ccf42110b665b3ed7e800aa (patch)
treed5077e1162cfecdf3bf2d87ae078fcef76ce0d91 /PKGBUILD
parent2d7f32e053829f76badb802c9ce985f19bb9cf4b (diff)
downloadaur-dvorak7min.tar.gz
patch and correct install dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f2af223150f..1f9944f10703 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,6 @@
-# Maintainer: Eric DeStefano <eric at ericdestefano dot com>
-# Contributor:Paul Bragg <paul2lv@gmail.com>
pkgname=dvorak7min
pkgver=1.6.1
-pkgrel=4
+pkgrel=5
pkgdesc="dvorak7min is a simple ncurses-based typing tutor for those trying to become fluent with the Dvorak keyboard layout"
arch=('i686' 'x86_64')
license=('GPL')
@@ -11,9 +9,15 @@ depends=('ncurses')
source=(http://http.debian.net/debian/pool/main/d/dvorak7min/dvorak7min_1.6.1+repack.orig.tar.gz)
md5sums=('e2c3e02b4f0cf24fcf29118d01f52956')
-package() {
- cd $startdir/src/$pkgname-$pkgver
- _installdir="$startdir/pkg/usr/bin"
- make INSTALL=$_installdir || return 1
- make INSTALL=$_installdir install || return 1
+
+build() {
+ cp $startdir/0001-sys_errlist-to-strerror.patch $pkgname-$pkgver
+ cd $pkgname-$pkgver
+ patch -p1 < 0001-sys_errlist-to-strerror.patch
+ make INSTALL="$pkgdir/usr/bin"
}
+
+package() {
+ cd $pkgname-$pkgver
+ make INSTALL="$pkgdir/usr/bin" install
+} \ No newline at end of file