summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin J. Pohly2022-06-07 15:18:46 -0500
committerDevin J. Pohly2022-06-07 15:18:46 -0500
commitfd502c7c8468299f2d4f05bf756f6da8ca74538c (patch)
treeb54ad9374d1d3144f6d26f98661177f8d731e2dc /PKGBUILD
parentaae44186ae4db542ff335b725d7091a782278d02 (diff)
downloadaur-dwl-git.tar.gz
no need to provide a duplicate config.def.h
It can be the user's responsibility to provide a custom configuration or not.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf500bc94087..030c80d131b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
pkgname=dwl-git
-pkgver=0.2.1.r17.823cefd
+pkgver=0.3.1.r27.d969289
pkgrel=1
pkgdesc="Simple, hackable dynamic tiling Wayland compositor (dwm for Wayland)"
arch=('x86_64')
@@ -18,7 +18,10 @@ sha256sums=('SKIP' 'SKIP')
prepare() {
cd "$srcdir/${pkgname%-git}"
- cp "$srcdir/config.h" config.h
+ # Use a custom config.h if the file is not empty
+ if [ -s "$srcdir/config.h" ]; then
+ cp -f "$srcdir/config.h" config.h
+ fi
# Uncomment to compile with XWayland support
#sed -i -e '/-DXWAYLAND/s/^#//' config.mk
}