summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2018-07-23 00:36:56 +0200
committerFabioLolix2018-07-23 00:36:56 +0200
commit29ef85398007a29819716259adf4b09326e06599 (patch)
treef36778b453f9b6e6a638072f98f201d1a86c4ed4 /PKGBUILD
downloadaur-29ef85398007a29819716259adf4b09326e06599.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0810a170a1e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+
+pkgname=easyssh
+pkgver=1.2.7
+pkgrel=1
+pkgdesc="SSH connection manager for Pantheon"
+arch=('x86_64')
+url='https://github.com/muriloventuroso/easyssh'
+license=('GPL3')
+depends=('libgranite.so' 'gtk3')
+makedepends=('vala' 'cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz")
+sha256sums=('a261ef8c99e2627691feb7c6f1ec296aae5a9e2e66ba2ad7eb1c232359838a2e')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ DESTDIR="${pkgdir}" ninja -C build install
+}