summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2018-09-25 00:23:49 +0200
committerFabioLolix2018-09-25 00:23:49 +0200
commit2d5887e33013c336d566fc3d6e3508900cadb29b (patch)
treefc7587d2b299ba3685b6ca272dde836b564347ca /PKGBUILD
parent928e90caa4e90f5cd46f85d089e0dfcb54ce3704 (diff)
downloadaur-2d5887e33013c336d566fc3d6e3508900cadb29b.tar.gz
Improve build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b96c936a71d..eb8b993b07cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,20 @@
pkgname=easyssh
pkgver=1.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="SSH connection manager for Pantheon"
arch=('x86_64')
url="https://github.com/muriloventuroso/easyssh"
license=(GPL3)
depends=(libgranite.so gtk3)
makedepends=(vala meson ninja)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz"
- 0001-fix-vte-build-error.patch)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz")
sha256sums=('d59eaa43d8c633db69dd75f44ee5c5b19c8df0144adb9c87187fbaf734a76548'
'1be1e1f1d654eafb31972320f1c94a17b7f35c4e938ceba8b6da122ab459cb48')
-prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i ../0001-fix-vte-build-error.patch
-}
-
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- meson build --prefix=/usr -D libunity=false
+ meson build --prefix=/usr -D libunity=false -D ubuntu-bionic-patched-vte=false
ninja -C build
}