summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2020-08-19 19:02:48 +0200
committerFabioLolix2020-08-19 19:02:48 +0200
commit866eefc3a49c7ef60c89ed053e6fc5f037b92384 (patch)
tree291baf18395cb3931b676e3ad8e3326d338150a2 /PKGBUILD
parentbad40dede5844b4d1bcf6874c31727e73cafef2b (diff)
downloadaur-866eefc3a49c7ef60c89ed053e6fc5f037b92384.tar.gz
fix build & update v1.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e613065b0d..6a2c7f57d537 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=easyssh
-pkgver=1.6.6
+pkgver=1.7.1
pkgrel=1
pkgdesc="SSH connection manager for Pantheon"
arch=(x86_64)
@@ -9,16 +9,23 @@ url="https://github.com/muriloventuroso/easyssh"
license=(GPL3)
depends=(libgranite.so gtk3 vte3)
makedepends=(vala meson ninja)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz")
-sha256sums=('9ca938b62c4adf2fe23e4b855b55fbc61297515434d1a042155efdb4ec60a371')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz"
+ "https://dev.getsol.us/file/data/j3xcc4frwhf7o7oj5b7q/PHID-FILE-xz47xj55kglr3mr7kyig/files_utf8.patch")
+sha256sums=('d81ff91aa23be9a29eddf41d4fb9bb5ed0282d513683506f6011f56058053bbf'
+ 'f5b4a7406b61d6f777abdfab6141cbf917ee469c49bac2445bb6d704cb82461f')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../files_utf8.patch
+}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
meson build --prefix=/usr -D libunity=false -D ubuntu-bionic-patched-vte=false
ninja -C build
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
DESTDIR="${pkgdir}" ninja -C build install
}