summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2018-09-23 22:53:25 +0200
committerFabioLolix2018-09-23 22:53:25 +0200
commit928e90caa4e90f5cd46f85d089e0dfcb54ce3704 (patch)
tree527cb7a8ca5a26423bb4296ef63d2c3b23352bd3 /PKGBUILD
parent29ef85398007a29819716259adf4b09326e06599 (diff)
downloadaur-928e90caa4e90f5cd46f85d089e0dfcb54ce3704.tar.gz
v1.3.4, with patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0810a170a1e3..7b96c936a71d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=easyssh
-pkgver=1.2.7
+pkgver=1.3.4
pkgrel=1
pkgdesc="SSH connection manager for Pantheon"
arch=('x86_64')
-url='https://github.com/muriloventuroso/easyssh'
-license=('GPL3')
-depends=('libgranite.so' 'gtk3')
-makedepends=('vala' 'cmake')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz")
-sha256sums=('a261ef8c99e2627691feb7c6f1ec296aae5a9e2e66ba2ad7eb1c232359838a2e')
+url="https://github.com/muriloventuroso/easyssh"
+license=(GPL3)
+depends=(libgranite.so gtk3)
+makedepends=(vala meson ninja)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz"
+ 0001-fix-vte-build-error.patch)
+sha256sums=('d59eaa43d8c633db69dd75f44ee5c5b19c8df0144adb9c87187fbaf734a76548'
+ '1be1e1f1d654eafb31972320f1c94a17b7f35c4e938ceba8b6da122ab459cb48')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 -i ../0001-fix-vte-build-error.patch
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- meson build --prefix=/usr
+ meson build --prefix=/usr -D libunity=false
ninja -C build
}