summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2021-02-27 22:50:37 +0100
committerFabioLolix2021-02-27 22:50:37 +0100
commitb290fb9f08d439989eabe054e2102e78180a56b8 (patch)
treec5b12e4df65fe8972e7481d4116c42aaac4cb574 /PKGBUILD
parentd167c21d71738662f1a6ca0325f0a53caed3c163 (diff)
downloadaur-b290fb9f08d439989eabe054e2102e78180a56b8.tar.gz
v1.7.6, fixed build finally
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52f769e1bd6a..d933e86d7143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
pkgname=easyssh
-pkgver=1.7.2
+pkgver=1.7.6
pkgrel=1
pkgdesc="SSH connection manager for Pantheon"
arch=(x86_64)
@@ -9,19 +9,12 @@ url="https://github.com/muriloventuroso/easyssh"
license=(GPL3)
depends=(libgranite.so gtk3 vte3)
makedepends=(vala meson ninja)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/easyssh-files_utf8.patch")
-sha256sums=('c9c5dae036fda6b1410a36308640525fc61479d61201dda919f41d2705272d7c'
- 'f5b4a7406b61d6f777abdfab6141cbf917ee469c49bac2445bb6d704cb82461f')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ../easyssh-files_utf8.patch
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/muriloventuroso/easyssh/archive/${pkgver}.tar.gz")
+sha256sums=('dde7f00a3a032d30e7566bd97250550d71dd825609be07a63384c5c00038f0ce')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- meson build --prefix=/usr -D libunity=false -D ubuntu-bionic-patched-vte=false
+ meson build --prefix=/usr -D libunity=false -D ubuntu-bionic-patched-vte=false -D patched-vte=true
ninja -C build
}