summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit42a5f7bd3a7ff7f556c65299a07424e41d1b2fd3 (patch)
treede8e2dac9eceb8b610a1b379c6218357e6a2c180 /PKGBUILD
downloadaur-eclipse-h2-database.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6af46b7a67f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jonathan Wiersma <archaur at jonw dot org>
+
+pkgname=eclipse-h2-database
+pkgver=1.1.117
+_reldate=20120119162704
+_pkgdate=201105142352
+pkgrel=2
+pkgdesc="Support for H2 databases in Eclipse"
+arch=('any')
+url="http://www.eclipse.org/orbit/"
+license=('EPL')
+depends=("eclipse")
+_mirror="http://www.eclipse.org/downloads/download.php?r=1&file="
+source=("$_mirror/tools/orbit/downloads/drops/R${_reldate}/repository/plugins/org.h2_${pkgver}.v${_pkgdate}.jar")
+_jar=$(basename $source)
+noextract=($_jar)
+
+package() {
+install -d $pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/eclipse/plugins || return 1
+install -m644 $srcdir/$_jar \
+ $pkgdir/usr/share/eclipse/dropins/${pkgname#eclipse-}/eclipse/plugins || return 1
+}
+
+md5sums=('4c7fb64c54bc630bf83f9a87b70982fe')
+