summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit101e78aae62810b94696564c664db36a51f7f15b (patch)
treefba91951f721b04a3c0be01892fb47f4c7fe2d82 /PKGBUILD
downloadaur-eclipse-phpeclipse.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b789b799ab7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 3892 2009-10-12 00:36:29Z cprimier $
+# Maintainer: Corrado Primier <bardo@aur.archlinux.org>
+# Contributor: Frank Oosterhuis <frank@scriptzone.nl>
+
+pkgname=eclipse-phpeclipse
+_reldate=200910091456
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="PHP - Support for the Eclipse IDE Framework"
+arch=('any')
+url="http://www.phpeclipse.com/"
+license=('CPL')
+depends=('eclipse')
+source=("http://downloads.sourceforge.net/phpeclipse/PHPEclipse-${pkgver}.${_reldate}PRD-bin.zip")
+md5sums=('979626fc167a77f019c729be91e3af60')
+
+build() {
+ _dest=${pkgdir}/usr/share/eclipse/dropins/${pkgname/eclipse-}/eclipse
+
+ cd ${srcdir}
+
+ # Features
+ find features -type f | while read _feature ; do
+ if [[ ${_feature} =~ (.*\.jar$) ]] ; then
+ install -dm755 ${_dest}/${_feature%*.jar}
+ cd ${_dest}/${_feature/.jar}
+ jar xf ${srcdir}/${_feature} || return 1
+ else
+ install -Dm644 ${_feature} ${_dest}/${_feature}
+ fi
+ done
+
+ # Plugins
+ find plugins -type f | while read _plugin ; do
+ install -Dm644 ${_plugin} ${_dest}/${_plugin}
+ done
+}
+
+# vim:set ts=2 sw=2 et: