summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-10-04 16:51:40 +0200
committerhaawda2018-10-04 16:51:40 +0200
commit49656aee881ad01f48aa39dd623e79d2c15ba823 (patch)
tree936fae0b35422ceeb385a435936e24bff1411f47 /PKGBUILD
downloadaur-emacs-commenter.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78edae810b69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-commenter
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Emacs' multiline-comment support package"
+arch=('any')
+url="https://stable.melpa.org/#/commenter"
+license=('GPL3')
+depends=('emacs')
+source=("https://stable.melpa.org/packages/commenter-$pkgver.el")
+sha256sums=('08ee2de60a52f6ebd9eef6025581a29abdd16b0ce8a3f9ebcc6f911546d5e9fa')
+
+build() {
+ emacs -Q -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/
+ install -Dm644 ${pkgname#emacs-}-$pkgver.el "$pkgdir"/usr/share/emacs/site-lisp/${pkgname#emacs-}.el
+ install -Dm644 ${pkgname#emacs-}-$pkgver.elc "$pkgdir"/usr/share/emacs/site-lisp/${pkgname#emacs-}.elc
+}