summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-19 07:54:37 +0200
committersballert2018-09-19 07:54:37 +0200
commit02b3dd70c7e8dc44d989b216ab070c8a1c3dddd4 (patch)
treec24d8e9244619f9e1ec9f5e02cc18680d03dff59 /PKGBUILD
downloadaur-emacs-evil-smartparens-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a21141818e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="expez"
+_gitrepo="evil-smartparens"
+
+pkgname=emacs-evil-smartparens-git
+pkgver=r96.026d4a3
+pkgrel=1
+pkgdesc="Evil integration for Smartparens"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs' 'emacs-evil' 'emacs-smartparens')
+makedepends=('git')
+provides=('emacs-evil-smartparens')
+conflicts=('emacs-evil-smartparens')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/${_gitrepo}/
+}