summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-03 07:50:10 +0200
committersballert2018-09-03 07:50:10 +0200
commitf4447ecda4dd4d36f10795fec73baffc3a0bff29 (patch)
treea5cab439d5dd2dad904dda8004ed094852426aff /PKGBUILD
downloadaur-emacs-fill-column-indicator-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a175614e55c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="alpaker"
+_gitrepo="Fill-Column-Indicator"
+
+pkgname=emacs-fill-column-indicator-git
+pkgver=r145.d2536b1
+pkgrel=1
+pkgdesc="An Emacs minor mode that graphically indicates the fill column."
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-fill-column-indicator')
+conflicts=('emacs-fill-column-indicator')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/fill-column-indicator/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/fill-column-indicator/
+}