summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-04-17 22:55:25 +0200
committerFabioLolix2023-04-17 22:55:25 +0200
commitd1e582c38997419d9377c4e2f016318ce89a4f26 (patch)
treed993af79cb511b7344c69069e848082036fb6205 /PKGBUILD
parent11a44fcb155c3392a7d25228cf2fd1a980f5c95c (diff)
downloadaur-emacs-ng-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 32 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e49a12870f1f..bda6a4940a42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
pkgname=emacs-ng-git
-pkgver=r149638.79390ea31d
-pkgrel=1
+pkgver=r166435.gb944567a113
+pkgrel=2
epoch=1
pkgdesc="A new approach to Emacs - Including TypeScript, Threading, Async I/O, and WebRender"
arch=(x86_64)
@@ -16,52 +16,61 @@ url="https://emacs-ng.github.io/emacs-ng/"
license=(GPL3)
depends=(texinfo libjpeg-turbo libtiff librsvg gpm giflib libxpm libotf m17n-lib gtk3 gnutls
jansson cairo harfbuzz ncurses libxml2 libxt zlib libgccjit)
-makedepends=(git rustup)
+makedepends=(git rustup python texlive-core clang)
provides=(emacs emacs-ng)
conflicts=(emacs emacs-ng)
source=("git+https://github.com/emacs-ng/emacs-ng.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
+ cd emacs-ng
printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${pkgname%-git}"
+ cd emacs-ng
rustup install "$(cat rust-toolchain)"
- RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
./autogen.sh
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- ./configure \
+ cd emacs-ng
+ RUSTUP_TOOLCHAIN=$(cat rust-toolchain)
+ ./configure CFLAGS="-Wl,-rpath,shared -Wl,--disable-new-dtags" \
--prefix=/usr \
--sysconfdir=/etc \
--libexecdir=/usr/lib \
--localstatedir=/var \
- --with-x-toolkit=gtk3 \
- --with-xft \
- --with-wide-int \
+ --with-json \
--with-modules \
- --with-cairo \
- --with-harfbuzz \
- --with-nativecomp \
- --with-webrender
+ --with-compress-install \
+ --with-threads \
+ --with-included-regex \
+ --with-zlib \
+ --with-libsystemd \
+ --with-rsvg \
+ --without-imagemagick \
+ --with-gpm \
+ --without-xaw3d \
+ --with-dbus \
+ --without-pop \
+ --with-mailutils \
+ --with-gsettings \
+ --disable-build-details
- make NATIVE_FULL_AOT=1 \
- PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH"
+ make V=1 PATH="$HOME/.rustup/toolchains/${RUSTUP_TOOLCHAIN}-$(uname -m)-unknown-linux-gnu/bin:$PATH" bootstrap
+ make pdf
}
package() {
- cd "${srcdir}/${pkgname%-git}"
- make DESTDIR="${pkgdir}/" install
+ cd emacs-ng
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-pdf
# remove conflict with ctags package
- mv "${pkgdir}/usr/bin/ctags" "${pkgdir}/usr/bin/ctags.emacs"
- mv "${pkgdir}/usr/share/man/man1/ctags.1.gz" "${pkgdir}/usr/share/man/man1/ctags.emacs.1"
-
+ mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
+ mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
+
# fix user/root permissions on usr/share files
- find "${pkgdir}/usr/share/emacs/${pkgver}" -exec chown root:root {} \;
+ find "$pkgdir"/usr/share/emacs -exec chown root:root {} \;
}