summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-09-09 15:26:08 +0200
committerhaawda2018-09-09 15:26:08 +0200
commitfd619c7f9851df4565a3bfd21ff4b9e7804aad7d (patch)
treef8e18da298da6ca3de366ab1c53a2e6e12a00cb9 /PKGBUILD
downloadaur-emacs-paredit.tar.gz
initial upload for merge of paredit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abb380df677e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=emacs-paredit
+pkgver=24
+_pkgname=paredit
+pkgrel=2
+pkgdesc="Emacs minor mode for pseudo-structurally editing Lisp code"
+arch=('any')
+url="http://www.emacswiki.org/emacs/ParEdit"
+license=('GPL')
+conflicts=('paredit')
+provides=('paredit')
+makedepends=('emacs')
+install=paredit.install
+source=("http://mumble.net/~campbell/emacs/${_pkgname}-${pkgver}.el")
+sha256sums=('6a1ead320d0fc3032d0359e6f66e3b62b065eea71f70a5315de0b06930b2e35e')
+
+build() {
+ cd "$srcdir"
+ emacs -Q -batch -f batch-byte-compile paredit-${pkgver}.el
+}
+
+package() {
+ cd "$srcdir"
+
+ install -D -m644 paredit-${pkgver}.elc \
+ "$pkgdir"/usr/share/emacs/site-lisp/paredit.elc
+ install -D -m644 paredit-${pkgver}.el \
+ "$pkgdir"/usr/share/emacs/site-lisp/paredit.el
+}
+