summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsballert2018-09-14 12:31:10 +0200
committersballert2018-09-14 12:31:10 +0200
commit2c4020037120abe08516b1866535543c206454d5 (patch)
treee7fca0d16245fed53069cf9fb8ec345d58893bd2 /PKGBUILD
downloadaur-emacs-treepy-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c8fcffc9532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: sballert <sballert@posteo.de>
+
+_gituser="volrath"
+_gitrepo="treepy.el"
+
+pkgname=emacs-treepy-git
+pkgver=r37.b40e6b0
+pkgrel=1
+pkgdesc="Generic tree traversing tools for Emacs Lisp"
+url="https://github.com/${_gituser}/${_gitrepo}"
+arch=('any')
+license=('GPL3')
+depends=('emacs')
+makedepends=('git')
+provides=('emacs-treepy')
+conflicts=('emacs-treepy')
+source=("git+https://github.com/${_gituser}/${_gitrepo}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitrepo"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitrepo"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "$_gitrepo"
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/treepy/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp/treepy/
+}