summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarvin Schlegel2020-08-15 19:51:28 +0200
committerMarvin Schlegel2020-08-15 19:51:28 +0200
commita8cdc7e619940d953da6bdfea59a9e28c2f57e36 (patch)
tree5310531e489848111b2e0d0a604bb5fbbff645c5 /PKGBUILD
parent485d72e9e6bb029546fec1b15f587796cffc0c06 (diff)
downloadaur-emacs27-git.tar.gz
Fix pkgver() for Emacs 27.1 versions
Thanks to pancho [1] and seds [2] :) Also updated pkgver value and SRCINFO. [1] https://aur.archlinux.org/account/pancho [2] https://aur.archlinux.org/account/seds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 435a62c8a39e..f5d1988cdd60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -70,8 +70,8 @@ NOGZ="YES" # Don't compress .el files.
################################################################################
pkgname="emacs27-git"
-pkgver=27.0.60.140075
-pkgrel=2
+pkgver=27.1.50.140516
+pkgrel=1
pkgdesc="GNU Emacs. emacs-27 release branch."
arch=('x86_64' )
url="http://www.gnu.org/software/emacs/"
@@ -164,7 +164,7 @@ pkgver() {
printf "%s.%s" \
"$(grep AC_INIT configure.ac | \
- sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\.[0-9]\+\?\).\+$/\1/')" \
+ sed -e 's/^.\+\ \([0-9]\+\.[0-9]\+\(\.[0-9]\+\)\?\).\+$/\1/')" \
"$(git rev-list --count HEAD)"
}