summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Kobayashi2019-06-28 07:37:40 +0900
committerChristopher Kobayashi2019-06-28 07:37:40 +0900
commitd4a4544f7a283dc31306ea63f3e59f372634a4b3 (patch)
tree4eee23bf59c1351c9888f0d22663e6a9781c3ee0 /PKGBUILD
parent7a1b2c4129ca7c7620e197815a7509ce196ae086 (diff)
downloadaur-emulationstation-themes.tar.gz
Add themes from RetroPie, normalize install directories, bump to 0.2-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 40 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5e7a1e26e80..a9b1f689bf20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,54 @@
# Contributor: Drew Liszewski <drew dot liszewski at gmail dot com>
-# Maintainer: Drew Liszewski
+# Maintainer: Christopher KOBAYASHI <software plus aur at disavowed dot jp>
pkgname=emulationstation-themes
-pkgver=0.1
-pkgrel=2
+pkgver=0.2
+pkgrel=1
pkgdesc="EmulationStation themes pack"
arch=('any')
url="http://aloshi.com/emulationstation"
license=('WTFPL')
groups=()
-makedepends=()
+makedepends=('git')
depends=()
install='emulationstation-themes.install'
-source=("${pkgname}-${pkgver}.zip::https://aloshi.com/es_downloads/es_themes_jan_20_2013.zip")
-md5sums=('d72d30690bce0f00ca6c276bbc5ff816')
+source=('https://aloshi.com/es_downloads/es_themes_jan_20_2013.zip'
+ 'https://emulationstation.org/downloads/themes/simple_latest.zip'
+ 'git+https://github.com/RetroPie/es-theme-carbon-centered.git'
+ 'git+https://github.com/RetroPie/es-theme-carbon-nometa.git'
+ 'git+https://github.com/RetroPie/es-theme-clean-look.git'
+ 'git+https://github.com/RetroPie/es-theme-color-pi.git'
+ 'git+https://github.com/RetroPie/es-theme-simple-dark.git'
+ 'git+https://github.com/RetroPie/es-theme-simplified-static-canela.git'
+ 'git+https://github.com/RetroPie/es-theme-turtle-pi.git'
+ )
+noextract=('es_themes_jan_20_2013.zip')
+sha256sums=('f6430cf382cbd9dbd17ef864ae47993d5c912c6a0023f8189d98809aebe49b79'
+ '567cc78d4aec1ef13893834c7e73c3eea91f50d096468c1ae40c973c502471ea'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
+
+prepare() {
+ mkdir -p xevin
+ bsdtar -xf es_themes_jan_20_2013.zip -C xevin/
+}
+
+build() {
+ rm -r -f ${srcdir}/*/.git*
+}
package() {
cd "${srcdir}"
install -d ${pkgdir}/usr/share/EmulationStation/themes
- cp -r ${srcdir}/* ${pkgdir}/usr/share/EmulationStation/themes/
+ cp -r ${srcdir}/{simple,xevin} ${pkgdir}/usr/share/EmulationStation/themes/
+ for i in carbon-centered carbon-nometa clean-look color-pi simple-dark \
+ simplified-static-canela turtle-pi; do
+ cp -r ${srcdir}/es-theme-${i} \
+ ${pkgdir}/usr/share/EmulationStation/themes/${i}
+ done
}