summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcerisson2018-03-29 14:45:54 +0200
committerMarcerisson2018-03-29 14:45:54 +0200
commitae774dc8d288e568c30462c46ae09b27ee0eb3d4 (patch)
treec1e3c7ba5fbe2990c5ccc7454c674c51d1b28d98 /PKGBUILD
downloadaur-epifortune.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9017bfb20f5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Marc Schmitt <marc.schmitt@marcerisson.space>
+# Contributor: Original maintainer: Mevouc <meven.courouble@vouc.me>
+pkgname=epifortune
+pkgver=v1.0
+pkgrel=1
+pkgdesc="A fortune-like program which provide quotes from Epiquote."
+arch=(any)
+url="https://github.com/Marcerisson/epifortune"
+license=('MIT')
+source=(git://github.com/Marcerisson/$pkgname/)
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname/
+ make || return 1
+}
+
+package() {
+ cd $pkgname/
+ sudo install -D -m755 ./$pkgname /usr/bin/$pkgname
+}
+
+check() {
+ cd $pkgname
+}