summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaczanowski Mateusz2020-01-12 22:47:06 +0100
committerKaczanowski Mateusz2020-01-12 22:47:06 +0100
commitd9367d939961d6ac82dc3ab70c75149cf40be852 (patch)
tree06e455582e959851b8edf483ebd07f69eb66bde3 /PKGBUILD
parent97fa8f54ddb996226daefa1fb1a65f8246149739 (diff)
downloadaur-epiphany-elf-binutils.tar.gz
update to newer binutils version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90c88142dc7b..6cd75fa59f83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Jonathan Scott Tinkham <sctincman@gmail.com>
+# Maintainer: Mateusz Kaczanowski <kaczanowski.mateusz@gmail.com>
# Adapted from arm-none-eabi-binutils by Anatol Pomozov <anatol.pomozov@gmail.com>
_target=epiphany-elf
pkgname=$_target-binutils
-pkgver=2.25
+pkgver=2.33.1
pkgrel=1
pkgdesc='A set of programs to assemble and manipulate binary and object files for the Adapteva Epiphany target'
-arch=(i686 x86_64)
+arch=(i686 x86_64 armv7h)
url='http://www.gnu.org/software/binutils/'
license=(GPL)
depends=(zlib)
source=(ftp://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2)
-sha1sums=('b46cc90ebaba7ffcf6c6d996d60738881b14e50d')
+sha1sums=('332c7df7e1830c1e756cf4a5542a7952200210c1')
build() {
cd binutils-$pkgver
@@ -45,7 +45,7 @@ package() {
make DESTDIR="$pkgdir" install
# Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/${_target}-{dlltool,nlmconv,windres,windmc}*
+ rm "$pkgdir"/usr/share/man/man1/${_target}-{dlltool,windres,windmc}*
# Remove info documents that conflict with host version
rm -rf "$pkgdir"/usr/share/info