summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-06-01 15:32:57 +0300
committerCaleb Maclennan2021-06-01 15:32:59 +0300
commit43c49c087384e640cb798d334c63758b85746ed0 (patch)
treee56f496e0805e8faf4462e579a66551ff735cda1 /PKGBUILD
parent844f8198d72ff824cd5ee565e62accbf6b7b59f6 (diff)
downloadaur-equestria-fonts.tar.gz
Adopt and overhaul broken packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e6fe8a7b68e..40dcc7b6c736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
pkgname=equestria-fonts
pkgver=20140909
-pkgrel=1
-pkgdesc="Based on the package logos for Hasbro's My Little Pony Line. Includes full alphabet, extended characters and punctuation, and Euro."
+pkgrel=2
+pkgdesc='Irregular, irreverent typeface based on logos for Hasbro’s My Little Pony Line'
arch=(any)
-url="http://www.dafont.com/equestria.font"
-license=("custom:Pixel Sagas Freeware Fonts")
-depends=(fontconfig xorg-font-utils)
-source=("equestria.zip::http://img.dafont.com/dl/?f=equestria")
-md5sums=('5cbfa71684abbfd0c901e16ad931c628')
+url='http://www.dafont.com/equestria.font'
+license=('custom:Pixel Sagas Freeware Fonts')
provides=(ttf-equestria)
conflicts=(ttf-equestria)
replaces=(ttf-equestria)
-install="$pkgname.install"
+source=("$pkgname-$pkgver-$pkgrel.zip::http://img.dafont.com/dl/?f=equestria")
+sha256sums=('d12fa57f66fb3e7ff5b5a12e6125bada73355c2d468099faabe5acc16177433a')
-package()
-{
- cd "$srcdir"
- find . -name '*.otf' -exec install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/"{} \;
- install -Dm644 "$srcdir/Font License.txt" "$pkgdir/usr/share/licenses/equestria-fonts/Font License.txt"
+package() {
+ install -Dpm644 -t "$pkgdir/usr/share/fonts/OTF/" *.otf
+ install -Dpm644 -t "$pkgdir/usr/share/licenses/$pkgname/" 'Font License.txt'
}