summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorS Garnica2024-05-22 22:12:33 +0200
committerS Garnica2024-05-22 22:12:33 +0200
commit068eb86ac5ba7414a156451fb198814bf1ac4060 (patch)
treec5f9ceb41e4c09d4f92d0936bedb4830c01031ff /PKGBUILD
parent57bdfa9580e74ec87b9437e91fde0e18c00603e7 (diff)
downloadaur-esphomeyaml.tar.gz
Update to 2024.5.2 and migrate to pyproject.toml
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd9a4fc95b5e..bd102fea831b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgbase=esphomeyaml
pkgname=esphome
-pkgver=2024.5.0
+pkgver=2024.5.2
pkgrel=0
pkgdesc="Solution for your ESP8266/ESP32 projects with Home Assistant"
url="https://github.com/esphome/ESPHome"
-depends=('python-setuptools'
+depends=('python-build' 'python-installer' 'python-wheel'
'python-voluptuous'
'python-yaml'
'python-paho-mqtt'
@@ -32,7 +32,7 @@ license=('MIT')
arch=('any')
replaces=('esphomeyaml')
source=("https://github.com/esphome/ESPHome/archive/${pkgver}.tar.gz")
-sha256sums=('d0178a2c6823d5c2fac069acf62b592d9c5cac532289d92596d05c751c016787')
+sha256sums=('6562fab0d0f994d8a17c5bf3cef1d50ef217536cf8704ddb8f630354564b9f84')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -41,12 +41,12 @@ prepare() {
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/${pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
check() {