summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfutpib2019-07-19 00:41:36 +0300
committerfutpib2019-07-19 00:41:36 +0300
commit765b62a0a14863eefc021106e9d9cbe02b1e64a1 (patch)
treeed525b940d924b6c264d41cd19feb8a7aa712cde /PKGBUILD
downloadaur-etlas-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63b00ca48533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+
+pkgname=etlas-git
+_pkgname=etlas
+pkgver=1.5.1.0.r136.gbbd7c55
+pkgrel=1
+pkgdesc='Etlas, the build tool and package manager for the Eta programming language'
+arch=('x86_64')
+url='https://github.com/typelead/etlas'
+license=(BSD3)
+depends=()
+makedepends=('stack')
+conflicts=('etlas')
+source=("${_pkgname}::git+https://github.com/typelead/etlas.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ stack build etlas
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ stack install --local-bin-path "${pkgdir}/usr/bin" etlas
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}