summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2014-03-06 20:31:16 +0000
committerThomas Weißschuh2014-03-06 20:31:16 +0000
commit24f54043a868e53c6939b56dd41dcfa1cb254ea1 (patch)
tree800f781751f1641e8dcfd3d12ec08c58cf6896af /PKGBUILD
parent6abf6760cc77d9713b7b178b6dd31e1d51e75044 (diff)
downloadaur-evd-git.tar.gz
update packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 13 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4819b930b63..fda8b1c41df1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,32 @@
-# Maintainer: Thomas Weißschuh <thomas_weissschuh || lavabit.com>
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+
pkgname=evd-git
-pkgver=20111031
+pkgver=20140125
pkgrel=1
pkgdesc="eventdance, a peer-to-peer inter-process communication library."
arch=(i686 x86_64)
-url="https://gitorious.org/eventdance/eventdance"
+url='https://github.com/elima/eventdance'
license=('LGPL')
-depends=(json-glib gjs libsoup util-linux)
+depends=(json-glib libsoup)
optdepends=('gtkdocise: generating api docs')
+source=('git+https://github.com/elima/EventDance')
provides=('evd')
makedepends=('git')
+sha256sums=('SKIP')
-_gitroot=git://gitorious.org/eventdance/eventdance
-_gitname=eventdance
build() {
- cd "${srcdir}"
- msg "Connecting to GIT server...."
-
- if [[ -d "${_gitname}" ]]; then
- cd "${_gitname}" && git pull origin
- msg "The local files are updated."
- else
- git clone "${_gitroot}" "${_gitname}"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
+ cd "${srcdir}"/EventDance
- rm -rf "${srcdir}/${_gitname}-build"
- git clone "${srcdir}/${_gitname}" "${srcdir}/${_gitname}-build"
- cd "${srcdir}/${_gitname}-build"
-
- #
- # BUILD HERE
- #
-
- # We got no gjs-gi, compiles fine though
- sed -i 's/^.*gjs-gi.*$//' m4/javascript.m4
- ./autogen.sh --enable-js=yes --enable-introspection=yes
- ./configure --prefix=/usr
+ ./autogen.sh --prefix=/usr
make
}
package() {
- cd "${srcdir}/${_gitname}-build"
+ cd "${srcdir}"/EventDance
make DESTDIR="${pkgdir}/" install
}
-# vim:set ts=2 sw=2 et:
+pkgver() {
+ date '+%Y%m%d'
+}