summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcoloursofnoise2023-08-23 15:39:59 -0700
committercoloursofnoise2023-08-23 15:39:59 -0700
commit1d214c9a5cdd0400375e59bc628723334ee727e6 (patch)
treec73f2df74ee9fc78101cd46c6b359da93a110dff /PKGBUILD
parentab86aedd585b74adc39be4ad3a6e4e1c0304ab50 (diff)
downloadaur-everest-mons.tar.gz
Update to 2.0.0, package generated manual pages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd5221c655d8..0e273b389fe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: coloursofnoise <coloursofthenoise at google mail>
pkgname=everest-mons
_name=mons
-pkgver=1.4.4
+pkgver=2.0.0
pkgrel=1
pkgdesc="Command-Line Installer and Manager for Celeste Modding"
url="https://github.com/coloursofnoise/mons"
@@ -11,7 +11,7 @@ depends=('python' 'python-dnfile' 'python-pefile' 'python-click' 'python-tqdm' '
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
conflicts=('mons')
source=("${_name}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('6ace58773bab8793819958ccb29dc3ee')
+md5sums=('cbf58a835e782af149bb05302153e012')
build() {
cd "${_name}-${pkgver}"
@@ -23,4 +23,10 @@ package() {
python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 extras/mons.desktop "${pkgdir}/usr/share/applications/mons.desktop"
+
+ cd mons/man
+ for mandir in *; do
+ install -d ${pkgdir}/usr/share/man/${mandir}
+ install -m644 ${mandir}/* ${pkgdir}/usr/share/man/${mandir}/
+ done
}