summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonrad Malik2021-07-29 10:37:44 +0200
committerKonrad Malik2021-07-29 10:37:44 +0200
commitddf7f9e04ce0148356bc4ccd2a57eddbcbb65598 (patch)
tree6cdfaf58550c28e9daa9c1d68d3782b5efb895ce /PKGBUILD
downloadaur-evernote-bin.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b55e6861c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Konrad Malik (https://konradmalik.github.io/)
+
+pkgname=evernote-bin
+pkgver=10.7.6
+buildver=2330
+pkgrel=1
+pkgdesc="Official Evernote client for Linux"
+arch=('x86_64')
+url="https://evernote.com/"
+license=('custom')
+provides=('evernote')
+depends=(
+ 'gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils'
+ 'at-spi2-core' 'util-linux-libs' 'libappindicator-gtk3' 'libsecret'
+)
+optdepends=('gnome-keyring: for credentials persistence after reboot')
+conflicts=('evernote-beta-bin' 'evernote-for-linux-bin')
+replaces=()
+install=$pkgname.install
+source=(
+ "https://cdn1.evernote.com/boron/linux/builds/Evernote-${pkgver}-linux-ddl-ga-${buildver}.deb"
+ )
+noextract=("Evernote-${pkgver}-linux-ddl-ga-${buildver}.deb")
+sha256sums=(
+ '14a920801f8865dadbc5a1544e8051bb0b7bb66535575459f4f372d89170342f'
+)
+
+package() {
+ # extract only data
+ bsdtar -O -xf "Evernote-${pkgver}-linux-ddl-ga-${buildver}.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+}