summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Golatofski2020-06-03 13:05:05 +0200
committerFelix Golatofski2020-06-03 13:05:05 +0200
commit294c9d490cbacd92732460f3b9680dfdf37a3713 (patch)
tree2cb10bd50ce990eb4f821e22de2a04db573ca715 /PKGBUILD
parent28c5f171d0f41f3b75d63ece05768a2f2199640f (diff)
downloadaur-excavator.tar.gz
Updated: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 067e9fe407bd..a164b9ee0660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
-# Maintainer: TheGoliath
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+
pkgname=excavator
-pkgrel=1
pkgver=1.5.14a
+pkgrel=2
pkgdesc="Excavator by NiceHash. NiceHash's proprietary low-level CUDA miner."
-arch=('x86_64')
+arch=("x86_64")
url="https://github.com/nicehash/excavator"
-license=('https://github.com/nicehash/excavator/blob/master/excavator-EULA.txt')
-groups=('')
+license=("custom")
depends=('nvidia-utils' 'libpciaccess' 'libx11>=1.4.99.1' 'libxext' 'ocl-icd>=1.0' 'cuda')
options=('!strip' '!emptydirs')
-source_x86_64=("https://github.com/nicehash/excavator/releases/download/v${pkgver}/excavator_${pkgver}_amd64.deb")
-sha512sums_x86_64=('d3f8b8903d249f5218470bcdfe73651d3a13062007d9b8658c7c93c65ef89c15b189fd71b3475c8ccf90399850774987d577e8a2f7a356f09c3a3806b12ac42b')
-
+source=("https://github.com/nicehash/excavator/releases/download/v${pkgver}/excavator_${pkgver}_amd64.deb"
+ "https://raw.githubusercontent.com/nicehash/excavator/master/excavator-EULA.txt")
+sha512sums=('d3f8b8903d249f5218470bcdfe73651d3a13062007d9b8658c7c93c65ef89c15b189fd71b3475c8ccf90399850774987d577e8a2f7a356f09c3a3806b12ac42b'
+ '281a4d333e7e3133d3779d2977ef9a9a2742c2f721118d29881e4543734f8201d909a3e78d8d2fb59904d6603a03db73caa280942fccd93949cab60eabc5cc37')
package(){
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
- msg2 "You should grab yourself a config from 'https://github.com/nicehash/excavator/blob/master/default_command_file.json'"
- msg2 "You can run excavator by specifying the path to the command file (excavator -c /tmp/default_command_file.json)"
+ tar --no-same-owner -xJC "$pkgdir" -f data.tar.xz
+ install -Dm644 $srcdir/excavator-EULA.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -rf "$pkgdir/opt"
}