summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2022-11-14 19:55:28 +0300
committerIgor Dyatlov2022-11-14 19:55:28 +0300
commitd30b9f436263e8f1aa9d11a33b50fc12d3d8ab1f (patch)
treeb7716e709f8f18e64094aa1011e6170f2f3b8053 /PKGBUILD
parent2716a25881d48caa4e7ff24e596f153e9da184c0 (diff)
downloadaur-extension-manager-git.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 507cba77140b..7c9baa860a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=extension-manager-git
-pkgver=r571.87bd7d0
+pkgver=0.4.0.r34.g5b1fa91
pkgrel=1
pkgdesc="A native tool for browsing, installing, and managing GNOME Shell Extensions"
arch=('x86_64' 'aarch64')
url="https://github.com/mjakeman/extension-manager"
license=('GPL3')
depends=('libadwaita' 'libsoup3' 'json-glib' 'text-engine' 'libbacktrace-git')
-makedepends=('git' 'meson' 'blueprint-compiler' 'gobject-introspection')
+makedepends=('git' 'meson' 'blueprint-compiler' 'gobject-introspection' 'python-gobject')
checkdepends=('appstream-glib')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -17,10 +17,7 @@ b2sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {