summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastien Duthil2017-06-18 22:09:01 -0400
committerSebastien Duthil2017-06-18 22:09:01 -0400
commitc15bbdd83b6fbf97f4f7207d50d60dee1c8c1fd0 (patch)
tree3385fab729f3de5b65481eb77f50609714ad6dac /PKGBUILD
parent9fcf632d0381c876361ba2fee2ca985ddcb7f774 (diff)
downloadaur-c15bbdd83b6fbf97f4f7207d50d60dee1c8c1fd0.tar.gz
add flag -r to read
reason: usernames/password/paths may contain backslashes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd51f4cd2cdf..5c7797070f09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -88,7 +88,7 @@ _find_pkgpath_from_dir() {
}
_find_pkgpath_from_input() {
- read -p "Please provide the path to the directory containing ${_gamepkg} (e.g. /home/joe). Leave blank to download from https://factorio.com: " pkgpath
+ read -rp "Please provide the path to the directory containing ${_gamepkg} (e.g. /home/joe). Leave blank to download from https://factorio.com: " pkgpath
}
_find_pkgpath_from_download() {
@@ -99,11 +99,11 @@ _find_pkgpath_from_download() {
local password
local file="${SRCDEST}/${_gamepkg}"
- read -p "Username or email: " login
+ read -rp "Username or email: " login
if [[ -z "${login}" ]]; then
break
fi
- read -sp "Password: " password ; echo
+ read -rsp "Password: " password ; echo
if [[ -z "${password}" ]]; then
break
fi