summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxi2024-02-17 17:42:03 +0100
committerMaxi2024-02-17 17:42:03 +0100
commitc9c0f2c6ca637f97be60d452d09c3d514ae7a2eb (patch)
tree660755997545853e6cd741bdfe18eebbfabb05a1 /PKGBUILD
parent3d0905f9a5389810148d96a6fa01cb0225f5d812 (diff)
downloadaur-falsedotnet.tar.gz
update to 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63b0d2add0a8..0495cf1e766b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: MixusMinimax <maxi.barmetler@gmail.com>
pkgname=falsedotnet
-pkgver=1.0.0alpha1
-_pkgver=1.0.0-alpha.1
+pkgver=1.0.0
+_pkgver=1.0.0
pkgrel=1
pkgdesc="An interpreter and compiler for the esoteric programming language False, implemented using .NET Core"
arch=('x86_64')
@@ -12,7 +12,7 @@ depends=('git' 'dotnet-runtime')
makedepends=('dotnet-sdk')
optdepends=('nasm: for assembling false programs')
source=("$url/archive/v$_pkgver.tar.gz")
-sha256sums=('fadcc64f35b824bfb9c71d88b66de8899052cdca419924868af1ecf3488ec2c4')
+sha256sums=('27a36bd5613811ea64e912ed5c4d69566d96d82921958bc8028370d6e1404433')
build() {
cd "$pkgname-$_pkgver/FalseDotNet.Cli"
@@ -21,6 +21,7 @@ build() {
--self-contained true \
--runtime linux-x64 \
-p:Version=$_pkgver \
+ -p:PublishTrimmed=true \
--output ../$pkgname \
./FalseDotNet.Cli.csproj
}