summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2023-06-12 16:21:56 -0400
committerGuillaume Horel2023-06-12 16:22:28 -0400
commitfa082e14612fe60992c209f20a8a9e78671984bd (patch)
tree6ea562d08f294675f3f9a7b7dfa8c27bb29d1fbe /PKGBUILD
parente685f9d329a3d1f2aaf17ece9a49c50e8b508729 (diff)
downloadaur-farmhash.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25a67288b4bf..76e6a6d9b7e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,37 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname='farmhash'
-pkgver='1.1'
-pkgrel=1
-pkgdesc="FarmHash is a family of hash functions"
+pkgname=farmhash
+pkgver=1.1
+pkgrel=2
+pkgdesc='FarmHash is a family of hash functions'
url="https://github.com/google/farmhash"
depends=('gcc-libs')
makedepends=('git')
checkdepends=()
license=('MIT')
arch=('x86_64')
-source=("git+https://github.com/google/farmhash.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/google/farmhash.git"
+ "namespace.patch")
+sha256sums=('SKIP'
+ 'e3f7e0c3a421e814305611395e4abf9734d4d96214815dfab384702a6772ba92')
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
+ patch -p1 -i ../namespace.patch
autoreconf -vif
./configure CXXFLAGS="-g -mavx -maes -O3" --prefix=/usr
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
make all
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
make DESTDIR="$pkgdir" install
}
check() {
- cd "${srcdir}/${pkgname}"
+ cd "${pkgname}"
make check
}